On Fri, 2016-10-07 at 15:02 +0100, David Woodhouse wrote:
> Tested with VDSL on TP-Link WD8970, I see full 1500-byte PPP data
> frames, which end up being 1526 byte Ethernet frames (including
> Ethernet+VLAN headers) on the wire.
> 
> Fixes: FS#210

So this got merged, and now it *can* work properly. But it doesn't. I
updated to 17.01 and I'm back to 1492-byte PPP.

I think I had also hacked my local build of the module so that not only
would it *permit* a 1508-byte MTU to be set, but it also *defaulted* to
that.

Now, it defaults to 1500 and needs userspace to *set* an MTU of 1508 on
the ptm0 and ptm0.101 VLAN interfaces... and I can't persuade netifd to
do that. I only get full frames if I set the MTU manually.

What am I missing?

config interface 'vdsl'
        option proto 'pppoe'
        option username 'xx'
        option password 'xx'
        option pppd_options 'debug'
        option ifname 'ptm0.101'
        option mtu '1500'
        option ipv6 'auto'

config route6
        option interface 'vdsl'
        option target '::/0'
        option metric '1'

config switch_vlan 'ptm0_101'
        option device 'ptm0'
        option vlan '101'
        option vid '101'

config interface 'aa101'
        option ifname 'ptm0.101'
        option proto 'none'
        option mtu '1508'
        option delegate '0'

config interface 'ptm0'
        option ifname 'ptm0'
        option proto 'none'
        option mtu '1508'
        option delegate '0'

Attachment: smime.p7s
Description: S/MIME cryptographic signature

_______________________________________________
Lede-dev mailing list
Lede-dev@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/lede-dev

Reply via email to