> dict() is an obvious one, but because of Python's verbose dict syntax
> (foo['bar'] not foo.bar) it makes code harder to read​

I used attrdict for awhile, and liked it for what I was doing at the time,
https://github.com/bcj/AttrDict.There is Box,
https://github.com/cdgriffith/Box which has a sizable following and is
active. Though this Redit thread has a number of reasoned thoughts on why
the idea of Dotted Notation is a bad idea in large projects:
https://www.reddit.com/r/Python/comments/2ew0y5/why_is_there_no_dotted_dict/
{shrug}

matt

-- 
You received this message because you are subscribed to the Google Groups 
"leo-editor" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to leo-editor+unsubscr...@googlegroups.com.
To post to this group, send email to leo-editor@googlegroups.com.
Visit this group at https://groups.google.com/group/leo-editor.
For more options, visit https://groups.google.com/d/optout.

Reply via email to