Hi,

On Wed, Apr 20, 2011 at 9:24 AM, Martin Storsjö <mar...@martin.st> wrote:
> This avoids clashes if we internally want to override the global
> open function.
> ---
>  libavformat/rdt.c          |    4 ++--
>  libavformat/rtpdec.h       |    4 ++--
>  libavformat/rtpdec_amr.c   |    8 ++++----
>  libavformat/rtpdec_asf.c   |    4 ++--
>  libavformat/rtpdec_h264.c  |    4 ++--
>  libavformat/rtpdec_latm.c  |    4 ++--
>  libavformat/rtpdec_mpeg4.c |    8 ++++----
>  libavformat/rtpdec_qcelp.c |    4 ++--
>  libavformat/rtpdec_qdm2.c  |    4 ++--
>  libavformat/rtpdec_qt.c    |    4 ++--
>  libavformat/rtpdec_svq3.c  |    4 ++--
>  libavformat/rtpdec_vp8.c   |    4 ++--
>  libavformat/rtpdec_xiph.c  |    8 ++++----
>  libavformat/rtsp.c         |    6 +++---
>  14 files changed, 35 insertions(+), 35 deletions(-)
>
> diff --git a/libavformat/rdt.c b/libavformat/rdt.c
> index dfb31d1..1c6452d 100644
> --- a/libavformat/rdt.c
> +++ b/libavformat/rdt.c
> @@ -551,8 +551,8 @@ static RTPDynamicProtocolHandler ff_rdt_ ## n ## _handler 
> = { \
>     .codec_type       = t, \
>     .codec_id         = CODEC_ID_NONE, \
>     .parse_sdp_a_line = rdt_parse_sdp_line, \
> -    .open             = rdt_new_context, \
> -    .close            = rdt_free_context, \
> +    .rtp_open         = rdt_new_context, \
> +    .rtp_close        = rdt_free_context, \

A little ugly, but I guess it's OK. You could also (while you're at
it) rename them to alloc_rtp_context and free_rtp_context or something
along those lines.

Ronald
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to