On Wed, 2011-12-21 at 19:45 +0100, Janne Grunau wrote:
> From: Tomas Härdin <tomas.har...@codemill.se>
> 
> ---
>  libavformat/mxfdec.c |  108 
> +++++++++++++++++++++++++++++++++++++++++++++++++-
>  1 files changed, 107 insertions(+), 1 deletions(-)
> 
> diff --git a/libavformat/mxfdec.c b/libavformat/mxfdec.c
> index c4c3f59..b8767c2 100644
> --- a/libavformat/mxfdec.c
> +++ b/libavformat/mxfdec.c
> @@ -52,6 +52,35 @@
>  #include "internal.h"
>  #include "mxf.h"
>  
> +typedef enum {
> +    PART_TYPE_HEADER,
> +    PART_TYPE_BODY,
> +    PART_TYPE_FOOTER
> +} MXFPartitionType;

I hate to bikeshed, but these names should really stay CamelCase. Such
is the way the spec and all other MXF software names them, especially
mxfdump. MXF is complicated as it is without increasing impedance.
(Yes, I know I should have raised a fuzz earlier)

/Tomas

_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to