On Sat, 07 Jul 2012 17:28:02 +0200, Diego Biurrun <di...@biurrun.de> wrote:
> On Thu, Jul 05, 2012 at 09:57:35PM +0200, Anton Khirnov wrote:
> > 
> > --- /dev/null
> > +++ b/tests/fate/filter.mak
> > @@ -0,0 +1,23 @@
> > +FATE_AMIX += fate-filter-amix-simple
> > +fate-filter-amix-simple: CMD = avconv -filter_complex amix -i $(SRC) -ss 3 
> > -i $(SRC1) -f f32le -
> > +fate-filter-amix-simple: REF = $(SAMPLES)/filter/amix_simple.pcm
> > +
> > +FATE_AMIX += fate-filter-amix-first
> > +fate-filter-amix-first: CMD = avconv -filter_complex amix=duration=first 
> > -ss 4 -i $(SRC) -i $(SRC1) -f f32le -
> > +fate-filter-amix-first: REF = $(SAMPLES)/filter/amix_first.pcm
> 
> alphabetical order of test names
> 
> > +FATE_AMIX += fate-filter-amix-transition
> > +fate-filter-amix-transition: tests/data/asynth-44100-2-3.wav
> > +fate-filter-amix-transition: SRC2 = tests/data/asynth-44100-2-3.wav
> > +fate-filter-amix-transition: CMD = avconv -filter_complex 
> > amix=inputs=3:dropout_transition=0.5 -i $(SRC) -ss 2 -i $(SRC1) -ss 4 -i 
> > $(SRC2) -f f32le -
> > +fate-filter-amix-transition: REF = $(SAMPLES)/filter/amix_transition.pcm
> 
> I see no point in defining SRC2 and only using it once.
> 

Makes avconv commandlines shorter and more readable.

> > +$(FATE_AMIX): tests/data/asynth-44100-2.wav tests/data/asynth-44100-2-2.wav
> > +$(FATE_AMIX): SRC  = tests/data/asynth-44100-2.wav
> > +$(FATE_AMIX): SRC1 = tests/data/asynth-44100-2-2.wav
> > +$(FATE_AMIX): CMP  = oneoff
> 
> SRC/SRC1 are not particularly good variable names.
> Replace them by something related to the test files please.

That's exactly what they are. Arbitrary source 1 and arbitrary source 2.

-- 
Anton Khirnov
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to