Hi,

On Sat, Jul 21, 2012 at 2:39 PM, Justin Ruggles
<justin.rugg...@gmail.com> wrote:
>  %macro VECTOR_CLIP_INT32 2
>  cglobal vector_clip_int32, 5,5,11, dst, src, min, max, len
> +    SPLATD_LOW m4, minm
> +    SPLATD_LOW m5, maxm
>  %if notcpuflag(sse4) && cpuflag(sse2) && notcpuflag(atom)
> -    cvtsi2ss   m4, minm
> -    cvtsi2ss   m5, maxm
> +    cvtdq2ps   m4, m4
> +    cvtdq2ps   m5, m5
>      %assign is_float 1
>  %else

Doesn't this add an instruction?

There's only one user left of SPLATD (sws), isn't it easier to rewrite
that to use this also, and remove SPLATD and rename this to SPLATD
again?

Ronald
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to