On Tue, Aug 21, 2012 at 06:34:00PM -0700, Alex Converse wrote:
> ---
>  Changelog                     |    1 +
>  doc/filters.texi              |   30 ++++++
>  libavfilter/Makefile          |    1 +
>  libavfilter/af_asetnsamples.c |  210 
> +++++++++++++++++++++++++++++++++++++++++
>  libavfilter/allfilters.c      |    1 +
>  5 files changed, 243 insertions(+), 0 deletions(-)
>  create mode 100644 libavfilter/af_asetnsamples.c

version bump

> --- a/doc/filters.texi
> +++ b/doc/filters.texi
> @@ -175,6 +175,36 @@ stream ends. The default value is 2 seconds.
>  
> +@section asetnsamples
> +
> +Set the number of samples per each output audio frame.

s/per/for/

> +The last output packet may contain a different number of samples, as
> +the filter will flush all the remaining samples when the input audio
> +signal its end.

reaches its end ?

> +@item nb_out_samples, n
> +Set the number of frames per each output audio frame. The number is
> +intended as the number of samples @emph{per each channel}.

s/as the/to be/

> --- /dev/null
> +++ b/libavfilter/af_asetnsamples.c
> @@ -0,0 +1,210 @@
> +
> +    av_audio_fifo_read(asns->fifo,
> +                       (void **)outsamples->extended_data, nb_out_samples);

Why the cast, void** should be compatible with uint8_t**...

> +    av_audio_fifo_write(asns->fifo, (void **)insamples->extended_data, 
> nb_samples);

same

> +    .description    = NULL_IF_CONFIG_SMALL("Set the number of samples for 
> each output audio frames."),

frame

> This is the functioning and tested version.
> 
> I might as well bring up the bikesheddy questions myself:
> 
> 1) Would fifo be a better name?

The current name sounds like alphabet soup to me.

Diego
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to