On Wednesday 19 February 2014 22:43:08 Luca Barbato wrote:
> +#define PX(op, x) \
> +    PU(x0 op ((x) << hshift))
> +#define PY(op, y) \
> +    PU(y0 op ((y) << vshift))

> +#define IS_INTRA(xop, x, yop, y) \
> +    MVF(PX(xop, x), PY(yop, y)).is_intra

This seems rather ugly, why not simply replace each "<< xshift" by "* (1 << 
xshift)" ?
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to