On Thu, Mar 20, 2014 at 12:45:36PM +0100, Diego Biurrun wrote:
> On Thu, Mar 20, 2014 at 03:14:55AM +0100, Vittorio Giovara wrote:
> > ---
> > My first encoder/decoder \o/
> 
> \o/
> 
> > --- a/libavcodec/Makefile
> > +++ b/libavcodec/Makefile
> > @@ -88,6 +88,8 @@ OBJS-$(CONFIG_AC3_FIXED_ENCODER)       += ac3enc_fixed.o 
> > ac3enc.o ac3tab.o ac3.o
> >  OBJS-$(CONFIG_AIC_DECODER)             += aic.o
> >  OBJS-$(CONFIG_ALAC_DECODER)            += alac.o alac_data.o
> >  OBJS-$(CONFIG_ALAC_ENCODER)            += alacenc.o alac_data.o
> > +OBJS-$(CONFIG_ALIAS_PIX_ENCODER)       += alias.o
> > +OBJS-$(CONFIG_ALIAS_PIX_DECODER)       += alias.o
> 
> order
> 
> > --- /dev/null
> > +++ b/libavcodec/alias.c
> 
> Maybe it should be called aliaspix, as the test?

Nah, it's more confusing this way.
 
> > +    bytestream2_skip(&g, 4); // obsolete offset
> 
> How is the offset obsolete?

By being X,Y coordinates of the image that were used back in the past but not
anymore.

> > +#if CONFIG_ALIAS_PIX_DECODER
> > +AVCodec ff_alias_pix_decoder = {
> > +    .name         = "alias_pix",
> > +    .long_name    = NULL_IF_CONFIG_SMALL("Alias/Wavefront PIX image"),
> > +    .type         = AVMEDIA_TYPE_VIDEO,
> > +    .id           = AV_CODEC_ID_ALIAS_PIX,
> > +    .decode       = decode_frame,
> > +    .capabilities = CODEC_CAP_DR1,
> > +};
> > +#endif
> > +
> > +#if CONFIG_ALIAS_PIX_ENCODER
> > +AVCodec ff_alias_pix_encoder = {
> > +    .name      = "alias_pix",
> > +    .long_name = NULL_IF_CONFIG_SMALL("Alias/Wavefront PIX image"),
> > +    .type      = AVMEDIA_TYPE_VIDEO,
> > +    .id        = AV_CODEC_ID_ALIAS_PIX,
> > +    .init      = encode_init,
> > +    .encode2   = encode_frame,
> > +    .close     = encode_close,
> > +    .pix_fmts  = (const enum AVPixelFormat[]) {
> > +        AV_PIX_FMT_RGB24, AV_PIX_FMT_RGBA, AV_PIX_FMT_GRAY8, 
> > AV_PIX_FMT_NONE
> > +    },
> > +};
> > +#endif
> 
> It seems this can be split easily, then it should be in two separate files.

then the filenames won't be so confusing as now
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to