On Thu, Jun 5, 2014 at 4:44 AM, Anton Khirnov <an...@khirnov.net> wrote:
>
> On Wed,  4 Jun 2014 14:33:01 -0400, Andrew Stone <and...@clovar.com> wrote:
>>
>> @@ -253,6 +254,7 @@ typedef struct AVOption {
>>          int64_t i64;
>>          double dbl;
>>          const char *str;
>> +        AVDictionary *dict;
>
> This change is not needed, since (as the comment above says) we do not allow
> default values for dicts and this union is only for holding the defaults.

Good call.

> Also, why the _val postfix? Why not call it just av_opt_get/set_dict?

Unfortunately, there already exists a function called av_opt_set_dict
which goes through all key/vals given in the input and calls
av_opt_set on them. To differentiate these functions from that, I
added the val suffix.
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to