On Thu, Feb 11, 2016 at 5:27 AM, Anton Khirnov <an...@khirnov.net> wrote:
> Quoting Vittorio Giovara (2016-02-09 22:43:13)
>> On Tue, Feb 9, 2016 at 4:02 PM, Anton Khirnov <an...@khirnov.net> wrote:
>> > ---
>> >  libavfilter/buffersrc.c | 2 +-
>> >  1 file changed, 1 insertion(+), 1 deletion(-)
>> >
>> > diff --git a/libavfilter/buffersrc.c b/libavfilter/buffersrc.c
>> > index f5b852f..0079f51 100644
>> > --- a/libavfilter/buffersrc.c
>> > +++ b/libavfilter/buffersrc.c
>> > @@ -327,7 +327,7 @@ static int request_frame(AVFilterLink *link)
>> >      }
>> >      av_fifo_generic_read(c->fifo, &frame, sizeof(frame), NULL);
>> >
>> > -    ff_filter_frame(link, frame);
>> > +    ret = ff_filter_frame(link, frame);
>> >
>> >      return ret;
>> >  }
>>
>> how about `return ff_filter_frame(link, frame);`
>
> To what end?

you coalesce two lines, skip an assignment, and imho make the flow more readable
-- 
Vittorio
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to