On 29/06/17 08:31, Diego Biurrun wrote:
> On Sun, Jun 18, 2017 at 07:08:02PM +0100, Mark Thompson wrote:
>> --- a/configure
>> +++ b/configure
>> @@ -190,6 +190,7 @@ External library support:
>>    --enable-avisynth          video frameserver
>>    --enable-avxsynth          Linux version of AviSynth
>>    --enable-bzlib             bzip2 compression [autodetect]
>> +  --enable-drm               DRM buffer sharing
>>    --enable-frei0r            video filtering plugins
>>    --enable-gnutls            crypto
>>    --enable-libbs2b           Bauer stereophonic-to-binaural DSP
>> @@ -1303,6 +1304,7 @@ EXTERNAL_LIBRARY_LIST="
>>      $EXTERNAL_LIBRARY_VERSION3_LIST
>>      avisynth
>>      avxsynth
>> +    drm
>>      frei0r
>>      gnutls
>>      libbs2b
> 
> I think "libdrm" would be a better name for the component. AFAIU it is
> the actual name of the library.

Sure; will change.

>> @@ -4734,6 +4736,7 @@ done
>>  enabled avisynth          && require_header avisynth/avisynth_c.h
>>  enabled avxsynth          && require_header avxsynth/avxsynth_c.h
>>  enabled cuda              && require cuda cuda.h cuInit -lcuda
>> +enabled drm               && require_pkg_config libdrm libdrm xf86drm.h 
>> drmGetVersion
> 
> The first argument should be the build-system-internal name of the component,
> this will not work quite as expected. See what I wrote above.

Ok.

>> --- /dev/null
>> +++ b/libavutil/hwcontext_drm.c
>> @@ -0,0 +1,281 @@
>> --- /dev/null
>> +++ b/libavutil/hwcontext_drm.h
>> @@ -0,0 +1,145 @@
>> +
>> +#ifndef AVUTIL_HWCONTEXT_DRM_H
>> +#define AVUTIL_HWCONTEXT_DRM_H
>> +
>> +#include "frame.h"
> 
> frame.h is not used,

AV_NUM_DATA_POINTERS

(Though there were thoughts that we could make this a new constant inside the 
header, probably with the value 4.  Still undecided on that one.)

>                      but stdint.h and sys/types.h are.

stddef.h and stdint.h are included by frame.h.  I don't see why sys/types.h 
would be needed?

> I think you also need to bump libavutil minor version.

Yes.  (Omitted for mergability while still seeking comments on the structure.)

Thanks,

- Mark

_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to