Hi Gary,

Den 2010-06-28 01:24 skrev Gary V. Vaughan:
Looking through the XSI substitutions, or more correctly the bash/ksh
func_append usage, there's room here to consistently use func_append
everywhere to make for easier maintenance... but rather than take the
additional overhead of a function call in the sensitive quadratic scaling
parts that prompted the introduction of the += idiom in the first place:
use the libtool rewriting  machinery to substitute inline `+=' where
possible, with a fallback to the earlier longhand otherwise.

Okay to push?
@@ -704,15 +710,14 @@ func_mode_compile ()
          save_ifs="$IFS"; IFS=','
          for arg in $args; do
            IFS="$save_ifs"
-           func_quote_for_eval "$arg"
-           lastarg="$lastarg $func_quote_for_eval_result"
+           func_append lastarg " $arg"
          done
          IFS="$save_ifs"
          func_stripname ' ' '' "$lastarg"

Oh, and this look suspicious...

s/func_append/func_append_quoted/ ?

Cheers,
Peter

Reply via email to