Mostly style changes and refactors. Ján Tomko (32): Initialize ret to -1 in nodeStateInitialize Split out pciaccess (de)initialization node_device_udev: initialize libpciaccess after the driver lock Reformat nodeStateCleanup Do not call nodeStateCleanup on early initialization error Assign node device driver private data earlier udevGetDMIData: remove unused variable udevProcessSCSIHost: use STRSKIP Rewrite usage of StrToLong_ui in udevProcess{PCI,SCSI} Remove udevStrToLong_ull Remove udevStrToLong_ui Remove udevStrToLong_i Do not VIR_STRDUP the string in udevGetDeviceProperty Move udevHasDeviceProperty earlier udevProcessFloppy; remove unnecessary allocation Fix the return value in udevKludgeStorageType Rewrite disk type checking in udevProcessStorage Only return two values in udevGetStringProperty Only return two values in udevGetUintProperty Remove extra allocation in udevGetDeviceSysfsAttr Only return two values in udevGetStringSysfsAttr Only return two values in udevGetIntSysfsAttr Only return two values in udevGetUintSysfsAttr Remove PROPERTY_* constants node_device_udev: switch to using virReportError udevProcessStorage: trim all whitespace from model and vendor Reformat udevProcessRemoveableMedia udevSetupSystemDev: return if allocation fails node_device_udev: remove yoda condition node_device_udev: remove unnecessary ret variables node_device_udev: rename labels to cleanup Add nomatch filters when enumerating udev devices
src/node_device/node_device_udev.c | 1156 ++++++++++++++---------------------- src/node_device/node_device_udev.h | 3 - 2 files changed, 437 insertions(+), 722 deletions(-) -- 2.7.3 -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list