On 12/2/20 11:13 AM, Peter Krempa wrote:
Fix the type for a variable holding flags to the usual 'unsigned int'
and change the name to be more appropriate to it's use.

s/it's/its


Reviewed-by: Daniel Henrique Barboza <danielhb...@gmail.com>


Signed-off-by: Peter Krempa <pkre...@redhat.com>
---
  src/conf/checkpoint_conf.c | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/conf/checkpoint_conf.c b/src/conf/checkpoint_conf.c
index 33b6699be7..8744ac83e1 100644
--- a/src/conf/checkpoint_conf.c
+++ b/src/conf/checkpoint_conf.c
@@ -157,12 +157,12 @@ virDomainCheckpointDefParse(xmlXPathContextPtr ctxt,
          def->parent.parent_name = virXPathString("string(./parent/name)", 
ctxt);

          if ((domainNode = virXPathNode("./domain", ctxt))) {
-            int domainflags = VIR_DOMAIN_DEF_PARSE_INACTIVE |
-                              VIR_DOMAIN_DEF_PARSE_SKIP_VALIDATE;
+            unsigned int domainParseFlags = VIR_DOMAIN_DEF_PARSE_INACTIVE |
+                                            VIR_DOMAIN_DEF_PARSE_SKIP_VALIDATE;

              def->parent.dom = virDomainDefParseNode(ctxt->node->doc, 
domainNode,
                                                      xmlopt, parseOpaque,
-                                                    domainflags);
+                                                    domainParseFlags);
              if (!def->parent.dom)
                  return NULL;
          } else {


Reply via email to