于 2011年07月14日 02:05, Eric Blake 写道:
On 07/13/2011 04:19 AM, Osier Yang wrote:
With small typo fixes (s/remote_generator/gendispatch/, and
s/remote_internal/remote_driver/)
---
  src/remote/qemu_protocol.x   |    2 +-
  src/remote/remote_driver.c   |    5 +++--
  src/remote/remote_protocol.x |   14 ++++++++++----
  src/remote_protocol-structs  |    4 ++++
  4 files changed, 18 insertions(+), 7 deletions(-)

diff --git a/src/remote/qemu_protocol.x b/src/remote/qemu_protocol.x
index fa453f4..9381f7c 100644
--- a/src/remote/qemu_protocol.x
+++ b/src/remote/qemu_protocol.x
@@ -43,7 +43,7 @@ const QEMU_PROTOCOL_VERSION = 1;

  enum qemu_procedure {
      /* Each function must have a two-word comment.  The first word is
-     * whether remote_generator.pl handles daemon, the second whether
+     * whether gendispatch.pl handles daemon, the second whether
If you haven't already pushed 1/8, then I'd squash these typo fixes into
that patch.

@@ -4177,6 +4177,7 @@ static virDriver remote_driver = {
      .domainCreateWithFlags = remoteDomainCreateWithFlags, /* 0.8.2 */
      .domainDefineXML = remoteDomainDefineXML, /* 0.3.0 */
      .domainUndefine = remoteDomainUndefine, /* 0.3.0 */
+    .domainUndefineWithFlags = remoteDomainUndefineWithFlags, /* 0.9.4 */
May reflect any API renaming.

      .domainAttachDevice = remoteDomainAttachDevice, /* 0.3.0 */
      .domainAttachDeviceFlags = remoteDomainAttachDeviceFlags, /* 0.7.7 */
      .domainDetachDevice = remoteDomainDetachDevice, /* 0.3.0 */
@@ -4244,7 +4245,7 @@ static virDriver remote_driver = {
      .domainMigratePerform3 = remoteDomainMigratePerform3, /* 0.9.2 */
      .domainMigrateFinish3 = remoteDomainMigrateFinish3, /* 0.9.2 */
      .domainMigrateConfirm3 = remoteDomainMigrateConfirm3, /* 0.9.2 */
-    .domainSendKey = remoteDomainSendKey, /* 0.9.3 */
+    .domainSendKey = remoteDomainSendKey /* 0.9.3 */
Spurious change.  Leave the trailing comma here.


Oops, yes.

+++ b/src/remote/remote_protocol.x
@@ -339,7 +339,7 @@ struct remote_node_get_memory_stats {
   * connection).  Errors are returned implicitly in the RPC protocol.
   *
   * Please follow the naming convention carefully - this file is
- * parsed by 'remote_generator.pl'.
+ * parsed by 'gendispatch.pl'.
Another typo fix to squash into 1/8.

@@ -2383,14 +2388,15 @@ enum remote_procedure {
      REMOTE_PROC_NODE_GET_CPU_STATS = 227, /* skipgen skipgen */
      REMOTE_PROC_NODE_GET_MEMORY_STATS = 228, /* skipgen skipgen */
      REMOTE_PROC_DOMAIN_GET_CONTROL_INFO = 229, /* autogen autogen */
-    REMOTE_PROC_DOMAIN_GET_VCPU_PIN_INFO = 230  /* skipgen skipgen */
+    REMOTE_PROC_DOMAIN_GET_VCPU_PIN_INFO = 230,  /* skipgen skipgen */
+    REMOTE_PROC_DOMAIN_UNDEFINE_WITH_FLAGS = 231  /* autogen autogen */

      /*
       * Notice how the entries are grouped in sets of 10 ?
       * Nice isn't it. Please keep it this way when adding more.
Oops - you missed the blank line that this comment asked for.

Conditional ACK once you split out the typo changes and account for any
API rename.


--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to