http://codereview.appspot.com/5293053/diff/12001/lily/page-layout-problem.cc
File lily/page-layout-problem.cc (right):

http://codereview.appspot.com/5293053/diff/12001/lily/page-layout-problem.cc#newcode79
lily/page-layout-problem.cc:79: footnotes_added = g->get_property
("footnote-stencil") != SCM_EOL;
Of course not :o$  I recommend to_boolean.  It returns true for
everything except SCM_EOL and SCM_BOOL_F.

http://codereview.appspot.com/5293053/diff/12001/lily/system.cc
File lily/system.cc (right):

http://codereview.appspot.com/5293053/diff/12001/lily/system.cc#newcode298
lily/system.cc:298: System::internal_get_note_heights_in_range (vsize
start, vsize end, bool foot)
I wanted to express my disgust.  Not the french "Ugh" that could refer
to your amerindian origins :)

http://codereview.appspot.com/5293053/diff/12001/lily/system.cc#newcode305
lily/system.cc:305: if (foot ? !to_boolean
(footnote_grobs[i]->get_property ("footnote")) : to_boolean
(footnote_grobs[i]->get_property ("footnote")))
Ok.  I thought footnote_grobs was only using footnotes.  Maybe you
should change the names of footnote_grobs and
get_footnote_grobs_in_range?
And change this long line for:
if (!to_boolean (footnote_grobs[i]->get_property ("footnote")))

http://codereview.appspot.com/5293053/diff/12001/scm/define-grob-properties.scm
File scm/define-grob-properties.scm (right):

http://codereview.appspot.com/5293053/diff/12001/scm/define-grob-properties.scm#newcode299
scm/define-grob-properties.scm:299: (footnote ,boolean? "Should this be
a footnote or in-note?")
Something like that.  I think "style" implicitly stands for "musical
notation style", so we need to find something better.

http://codereview.appspot.com/5293053/

_______________________________________________
lilypond-devel mailing list
lilypond-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-devel

Reply via email to