On Thu, Jun 30, 2005 at 07:59:51PM +0300, Artemio wrote: > As I understand I cannot change the names of _init and _fini because > these are standard for libraries (or not?) and names of > g_psStereoDescriptor and g_psMonoDescriptor are standard for a LADSPA > plgin (or not?)... But what should I do? Or is is better to keep the > plugins in separate .so files?
Just combine the two _init() functions into one, and the same for _fini(). Or change their names and add _init() and _fini() that call both. Or use static declarations of all the required LADSPA structs and then you don't need _init() and _fini() at all. -- FA