The LSM_AUDIT_DATA_TASK pid= and comm= labels are duplicates of those at the
start of this function with different values.  Rename them to their object
counterparts opid= and ocomm= to disambiguate.

Signed-off-by: Richard Guy Briggs <r...@redhat.com>
---
 security/lsm_audit.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/security/lsm_audit.c b/security/lsm_audit.c
index b526ddc..3323144 100644
--- a/security/lsm_audit.c
+++ b/security/lsm_audit.c
@@ -282,7 +282,7 @@ static void dump_common_audit_data(struct audit_buffer *ab,
                        pid_t pid = task_pid_nr(tsk);
                        if (pid) {
                                char comm[sizeof(tsk->comm)];
-                               audit_log_format(ab, " pid=%d comm=", pid);
+                               audit_log_format(ab, " opid=%d ocomm=", pid);
                                audit_log_untrustedstring(ab,
                                    memcpy(comm, tsk->comm, sizeof(comm)));
                        }
-- 
1.7.1

--
Linux-audit mailing list
Linux-audit@redhat.com
https://www.redhat.com/mailman/listinfo/linux-audit

Reply via email to