On Thu, Jun 09, 2011 at 03:28:09PM +0800, Li Dongyang wrote:
> --- a/fs/btrfs/volumes.h
> +++ b/fs/btrfs/volumes.h
> @@ -45,6 +45,7 @@ struct btrfs_device {
>       int running_pending;
>       u64 generation;
>  
> +     int discard;

can you pick a better name? this does not describe that it's the
capability of the device, but rather 'do a discard'.

something like has_discard, can_discard, has_trim, etc

>       int writeable;
>       int in_fs_metadata;
>       int missing;

otherwise the patch looks good (and matches my view how to do it). I
will test it eventually.


david
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to