On Fri, Nov 11, 2011 at 01:28:36PM +0100, David Sterba wrote:
> On Thu, Nov 10, 2011 at 05:57:07PM -0500, Josef Bacik wrote:
> > --- a/fs/btrfs/ctree.h
> > +++ b/fs/btrfs/ctree.h
> > @@ -2699,8 +2699,8 @@ struct extent_map *btrfs_get_extent(struct inode 
> > *inode, struct page *page,
> >                                 size_t pg_offset, u64 start, u64 end,
> >                                 int create);
> >  int btrfs_update_inode(struct btrfs_trans_handle *trans,
> > -                         struct btrfs_root *root,
> > -                         struct inode *inode);
> > +                  struct btrfs_root *root, struct inode *inode,
> > +                  int fallback);
> 
> Can you please add a helper __btrfs_update_inode which takes the
> argument, leave btrfs_update_inode as is and add
> btrfs_update_inode_fallback for the '1' case?
> 
> So you don't change every callsite of btrfs_update_inode and just those 4
> which need _fallback variant (the rest is 29, quite a lot).

I reworked this last night since I already have v2.  See my for-linus
branch.

-chris
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to