On Wed, Jul 03, 2013 at 09:25:17PM +0800, Miao Xie wrote:
> --- a/btrfs.c
> +++ b/btrfs.c
> @@ -247,6 +247,7 @@ const struct cmd_group btrfs_cmd_group = {
>               { "device", cmd_device, NULL, &device_cmd_group, 0 },
>               { "scrub", cmd_scrub, NULL, &scrub_cmd_group, 0 },
>               { "check", cmd_check, cmd_check_usage, NULL, 0 },
> +             { "chunk-recover", cmd_chunk_recover, cmd_chunk_recover_usage, 
> NULL, 0},

Better late than never, though the patches are already in master branch
and I am horribly late.

I don't like to see this very specific command in the first level of
command namespace. In the past we've proposed a group named 'rescue'
that would collect functions that are potentially dangerous but perform
certain tasks that can make a filesystem usable again.

Examples are select-super or zero-log that are now separate utilities.

As a related topic, I was thinking about intorducing a separate
namespace that would be declared unstable and any feature in development
would be free to use it and add/modify/delete commands and params as
needed. That way developers can focus on the feature itself and let the
user interface polishing for later.

And now the name of the namespace: how about _ ? It's short, will never
clash with any other command.


david
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to