Now as the there is path in arg, so instead of reading the path from
cur_device just get it from the caller, and so the purpose of cur_device
is to skip the device, so rename it to skip_dev. Also drop the comment
about different path being used for the same device, since now we will
have cli to clean any device that's not a concern any more.

Signed-off-by: Anand Jain <anand.j...@oracle.com>
---
v3: add btrfs_free_stale_device() fn description, as suggested by
    Nikolay
    Fix line with longer than 80 char
v2: btrfs_device::name is null when we have missing device and
    unmounted. So we still need to check for dev->name.

 fs/btrfs/volumes.c | 30 ++++++++++++++++--------------
 1 file changed, 16 insertions(+), 14 deletions(-)

diff --git a/fs/btrfs/volumes.c b/fs/btrfs/volumes.c
index 0bf3233859b6..6d3353ce50d8 100644
--- a/fs/btrfs/volumes.c
+++ b/fs/btrfs/volumes.c
@@ -607,8 +607,17 @@ static void pending_bios_fn(struct btrfs_work *work)
        run_scheduled_bios(device);
 }
 
-
-static void btrfs_free_stale_device(struct btrfs_device *cur_dev, char *path)
+/*
+ * btrfs_free_stale_device()
+ *  Search and remove all stale (devices which are not mounted) devices.
+ *  When both inputs are NULL, it will search and release all stale devices.
+ *  path:      Optional. When provided will it release all unmounted devices
+ *             matching this path only.
+ *  skip_dev:  Optional. Will skip this device when searching for the stale
+ *             devices.
+ */
+static void btrfs_free_stale_device(const char *path,
+                                   struct btrfs_device *skip_dev)
 {
        struct btrfs_fs_devices *fs_devs, *tmp_fs_devs;
        struct btrfs_device *dev, *tmp_dev;
@@ -622,20 +631,13 @@ static void btrfs_free_stale_device(struct btrfs_device 
*cur_dev, char *path)
                                         &fs_devs->devices, dev_list) {
                        int not_found;
 
-                       if (cur_dev && (cur_dev == dev || !dev->name))
+                       if (skip_dev && skip_dev == dev)
+                               continue;
+                       if (path && !dev->name)
                                continue;
 
-                       /*
-                        * Todo: This won't be enough. What if the same device
-                        * comes back (with new uuid and) with its mapper path?
-                        * But for now, this does help as mostly an admin will
-                        * either use mapper or non mapper path throughout.
-                        */
                        rcu_read_lock();
-                       if (cur_dev)
-                               not_found = strcmp(rcu_str_deref(dev->name),
-                                                  
rcu_str_deref(cur_dev->name));
-                       else if (path)
+                       if (path)
                                not_found = strcmp(rcu_str_deref(dev->name), 
path);
                        else
                                not_found = 0;
@@ -784,7 +786,7 @@ static noinline int device_list_add(const char *path,
 
                ret = 1;
                device->fs_devices = fs_devices;
-               btrfs_free_stale_device(device, NULL);
+               btrfs_free_stale_device(path, device);
        } else if (!device->name || strcmp(device->name->str, path)) {
                /*
                 * When FS is already mounted.
-- 
2.7.0

--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to