On Wed, Jun 20, 2018 at 10:03:31AM -0700, Bart Van Assche wrote:
>               if (list_empty(&cache->dirty_list)) {
>                       list_add_tail(&cache->dirty_list,
>                                     &trans->transaction->dirty_bgs);
> -                             trans->transaction->num_dirty_bgs++;
> +                     trans->transaction->num_dirty_bgs++;

>               if (!block_group_bits(block_group, flags)) {
> -                 u64 extra = BTRFS_BLOCK_GROUP_DUP |
> +                     u64 extra = BTRFS_BLOCK_GROUP_DUP |
>                               BTRFS_BLOCK_GROUP_RAID1 |
>                               BTRFS_BLOCK_GROUP_RAID5 |
>                               BTRFS_BLOCK_GROUP_RAID6 |

In the two cases the indentation makes the code less readable, but

> -      struct btrfs_ioctl_ino_lookup_args *args;
> -      struct inode *inode;
> +     struct btrfs_ioctl_ino_lookup_args *args;
> +     struct inode *inode;

> -              if (!dev->bdev)
> +             if (!dev->bdev)
>                       continue;

this is purely whitespace change that is not applied in general. You
mention that it's reported by smatch, that would be a reason to fix it
so the output is less noisy.
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to