On Fri, Apr 20, 2007, Mauro Carvalho Chehab wrote:
> Argh! Too much flood for two simple defines!

I _think_ the point Mike was driving at is that there
is an established coding pattern of having a

struct foo_config {
        u8 i2c_addr;
        ...
};

If you use that then the #define is (at least) superflous,
"foo_tuner.i2c_addr = 0x62;" does the job.

If you don't use it, then the #define increases readability.
However, experience shows that soon enough there'll be
another similar device with a different i2c_addr so it makes
sense to use the pattern right from the start.


HTH,
Johannes

_______________________________________________
linux-dvb mailing list
linux-dvb@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

Reply via email to