On Monday, February 07, 2011, Mark Brown wrote: > It is very rare to find a current system which is both sufficiently > resource constrained to want to compile out power management support > and sufficiently power insensitive to be able to tolerate doing so. > Since having the configuration option requires non-zero effort to > maintain, with ifdefery in most drivers, but it is used with vanishing > rarity it is simpler to just remove the option. > > Begin doing so by hiding it from users - this should attract complaints > from any active users. The option is left disabled for the IA64 Ski > simulator which is a partial simulator for IA64 systems mostly missing > device support. This is a very limited use case which is unlikely to > ever want to enable most drivers. > > Signed-off-by: Mark Brown <broo...@opensource.wolfsonmicro.com> > --- > kernel/power/Kconfig | 21 ++------------------- > 1 files changed, 2 insertions(+), 19 deletions(-) > > diff --git a/kernel/power/Kconfig b/kernel/power/Kconfig > index 2657299..99e3c52 100644 > --- a/kernel/power/Kconfig > +++ b/kernel/power/Kconfig > @@ -1,23 +1,6 @@ > config PM > - bool "Power Management support" > - depends on !IA64_HP_SIM > - ---help--- > - "Power Management" means that parts of your computer are shut > - off or put into a power conserving "sleep" mode if they are not > - being used. There are two competing standards for doing this: APM > - and ACPI. If you want to use either one, say Y here and then also > - to the requisite support below. > - > - Power Management is most important for battery powered laptop > - computers; if you have a laptop, check out the Linux Laptop home > - page on the WWW at <http://www.linux-on-laptops.com/> or > - Tuxmobil - Linux on Mobile Computers at <http://www.tuxmobil.org/> > - and the Battery Powered Linux mini-HOWTO, available from > - <http://www.tldp.org/docs.html#howto>. > - > - Note that, even if you say N here, Linux on the x86 architecture > - will issue the hlt instruction if nothing is to be done, thereby > - sending the processor to sleep and saving power. > + bool > + default y if !IA64_HP_SIM > > config PM_DEBUG > bool "Power Management Debug Support"
I think it would be better to simply rename CONFIG_PM_OPS into CONFIG_PM. However, there's a number of things that I'm afraid wouldn't build correctly if none of CONFIG_PM_SLEEP and CONFIG_PM_RUNTIME were set in that case. Anyway, I'll try to prepare a patch doing that and see what happens. Stay tuned. Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe linux-embedded" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html