On Sat, Jun 11, 2022 at 1:56 PM Al Viro <v...@zeniv.linux.org.uk> wrote: > > On Sat, Jun 11, 2022 at 12:37:44PM +0000, Al Viro wrote: > > On Sat, Jun 11, 2022 at 12:12:47PM +0000, Al Viro wrote: > > > > > > > At a guess, should be > > > return min((size_t)nr * PAGE_SIZE - offset, maxsize); > > > > > > in both places. I'm more than half-asleep right now; could you verify > > > that it > > > (as the last lines of both iter_xarray_get_pages() and > > > iter_xarray_get_pages_alloc()) > > > builds correctly? > > > > No, I'm misreading it - it's unsigned * unsigned long - unsigned vs. size_t. > > On arm it ends up with unsigned long vs. unsigned int; functionally it *is* > > OK (both have the same range there), but it triggers the tests. Try > > > > return min_t(size_t, nr * PAGE_SIZE - offset, maxsize); > > > > there (both places). > > The reason we can't overflow on multiplication there, BTW, is that we have > nr <= count, and count has come from weirdly open-coded > DIV_ROUND_UP(size + offset, PAGE_SIZE) > IMO we'd better make it explicit, so how about the following:
Thanks. Fixed the build for me. -- Regards Sudip