> 
> From: Zhang Rui <[EMAIL PROTECTED]>
> File name should be unique in the same directory.
> 
> In order to keep the back-compatibility, only a warning is given
> currently, but actions must be taken to fix it when such duplicates
> are detected.
> 
> Bug report and a simple fix can be found here: 
> http://bugzilla.kernel.org/show_bug.cgi?id=8798
> 
> Signed-off-by: Zhang Rui <[EMAIL PROTECTED]>
> ---
>  fs/proc/generic.c |   12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> Index: linux-2.6/fs/proc/generic.c
> ===================================================================
> --- linux-2.6.orig/fs/proc/generic.c
> +++ linux-2.6/fs/proc/generic.c
> @@ -523,6 +523,7 @@ static const struct inode_operations pro
>  
>  static int proc_register(struct proc_dir_entry * dir, struct
> proc_dir_entry * dp)

Your email client is wordwrapping the text.

>  {
> +     struct proc_dir_entry *tmp = NULL;

That initialisation is unneeded - I removed it.

`tmp' is always a crappy name for anything.  I renamed it to `de'.


-
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to