On 2008-03-03T17:10:10, David Lee <[EMAIL PROTECTED]> wrote:

> But if any patch causes any trouble, feel free to back it out; they should
> all be independent of each other.  But preferably do so in an amended form
> that includes a comment about why the original code was the way it was.

Hi David,

http://hg.linux-ha.org/dev/rev/b71a9500faa3

greatly reduces readability. The [0] array trick is a very common
approach, and I know of no compiler which cannot handle this.

http://hg.linux-ha.org/dev/rev/fdfc8903459c

This, too, reduces readability a _lot_. Is that the best approach? The
Linux kernel uses named initializers too, but a form like

static struct scsi_host_template idescsi_template = {
        .module                 = THIS_MODULE,
        .name                   = "idescsi",
        .info                   = idescsi_info,
        .slave_configure        = idescsi_slave_configure,

Notice the leading "."; does that work on your compilers?

Otherwise, ordering matters for these long, long lists, which makes code
maintenance a pain. Are you sure the order is right in your cleanups?

Portability is alright, but there comes a point where modern language
features such as ISO C99 really help. It's 2008, afterall ;-)

Please, do not improve portability at the cost of code maintenance
effort.


Regards,
    Lars

-- 
Teamlead Kernel, SuSE Labs, Research and Development
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
"Experience is the name everyone gives to their mistakes." -- Oscar Wilde

_______________________________________________________
Linux-HA-Dev: Linux-HA-Dev@lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha-dev
Home Page: http://linux-ha.org/

Reply via email to