On Sun, 2024-02-11 at 09:16:33 UTC, Erick Archer wrote: > This is an effort to get rid of all multiplications from allocation > functions in order to prevent integer overflows [1]. > > As the "chip" variable is a pointer to "struct mtk_nfc_nand_chip" and > this structure ends in a flexible array: > > struct mtk_nfc_nand_chip { > [...] > u8 sels[] __counted_by(nsels); > }; > > the preferred way in the kernel is to use the struct_size() helper to > do the arithmetic instead of the argument "size + count * size" in the > devm_kzalloc() function. > > This way, the code is more readable and safer. > > Link: > https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > [1] > Link: https://github.com/KSPP/linux/issues/160 [2] > Reviewed-by: Gustavo A. R. Silva <gustavo...@kernel.org> > Signed-off-by: Erick Archer <erick.arc...@gmx.com> > Acked-by: Uwe Kleine-König <u.kleine-koe...@pengutronix.de> > Reviewed-by: AngeloGioacchino Del Regno > <angelogioacchino.delre...@collabora.com> > Reviewed-by: Matthias Brugger <matthias....@gmail.com>
Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next, thanks. Miquel