On Tue, 9 Jul 2024 at 22:28, Kees Cook <k...@kernel.org> wrote: > > On Tue, Jul 09, 2024 at 10:26:32AM -0700, Christoph Lameter (Ampere) wrote: > > On Mon, 8 Jul 2024, Kees Cook wrote: > > > > > > > > obj = kmalloc(obj, gfp); > > > > Could we avoid repeating "obj" in this pattern? > > > > F.e. > > > > KMALLOC(obj, gfp); > > This appears to be the common feedback, which is good! :) And we can > still have it return "obj" as well, so it could still be used in > "return" statements, etc. I will work up a new RFC...
More macros like this only obfuscate the code further. The name would become something that makes it really clear there's an assignment. assign_kmalloc(obj, gfp) There may be better options. Also ALLCAPS could be avoided here, as we have done with other language-like features (vs. pure constants).