Hello.

Bartlomiej Zolnierkiewicz wrote:

Index: b/drivers/ide/pci/cmd64x.c
===================================================================
--- a/drivers/ide/pci/cmd64x.c
+++ b/drivers/ide/pci/cmd64x.c
@@ -695,9 +695,10 @@ static void __devinit init_hwif_cmd64x(i
     hwif->swdma_mask = 0x07;

     if (dev->device == PCI_DEVICE_ID_CMD_643)
-             hwif->ultra_mask = 0x80;
+             hwif->ultra_mask = 0x00;
     if (dev->device == PCI_DEVICE_ID_CMD_646)
-             hwif->ultra_mask = (class_rev > 0x04) ? 0x07 : 0x80;
+             hwif->ultra_mask =
+                     (class_rev == 0x05 || class_rev == 0x07) ? 0x07 : 0x00;
     if (dev->device == PCI_DEVICE_ID_CMD_648)
             hwif->ultra_mask = 0x1f;

  Hm, well, this doesn't look consistent with the changes in other drivers.
This driver asks for explicit hwif->cds->ultra_mask initializers, IMO...
  You'd only have to check for PCI-646 revisions < 5 then...

reworked

   Thanks. :-)

Index: b/drivers/ide/pci/piix.c
===================================================================
--- a/drivers/ide/pci/piix.c
+++ b/drivers/ide/pci/piix.c
             default:
                     if (!hwif->udma_four)
                             hwif->udma_four = piix_cable_detect(hwif);

  This one also certainly asks for explicit hwif->cds->ultra_mask
initializers... Thus almost all of this switch statement could go away...
        
Alas doing it now would make the nice DECLARE_PIIX_DEV() macro go away

   Why? Could add another argument to that macro...

(=> a lot of duplicated code)... could be done in the future...

   Yes, of course.

Thanks,
Bart

MBR, Sergei
-
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to