On Jan 29, 2008 2:26 PM, Dmitry Torokhov <[EMAIL PROTECTED]> wrote:
> Hi Eric,
>
> On Wednesday 23 January 2008 02:16, eric miao wrote:
> > Subject: [PATCH] pxa: rename the pxa27x_keyboard to pxa27x_keypad
> >
> > The controller should really be called keypad, and also align
> > the naming of functions and structures to use "pxa27x_keypad"
> > as prefix, instead of "pxakbd".
>
> Not sure what the difference is... Seems to be a gratuous renaming.
>

Yeah, though I used git-mv, the result of git-format-patch still looks horrible.
Anyway, this is just a naming issue. While other pxa drivers are slowly
transitioning to a more standard naming convention (if you take a look at
recent [arch/arm/mach-pxa/devices.c] in Linus's recent tree) I first update
this to later patches could be more specific.

Another reason I don't like pxa27x_keyboard is it's too long, really not
suitable as a prefix, and "pxakbd" reads a bit awkward.

> --
> Dmitry
>



-- 
Cheers
- eric
-
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to