Hi Ping,

On Fri, Nov 15, 2013 at 12:00:02PM -0800, Ping Cheng wrote:
>> @@ -856,6 +856,7 @@ struct input_keymap_entry {
>  #define SW_FRONT_PROXIMITY   0x0b  /* set = front proximity sensor active */
>  #define SW_ROTATE_LOCK               0x0c  /* set = rotate locked/disabled */
>  #define SW_LINEIN_INSERT     0x0d  /* set = inserted */
> +#define SW_TOUCH             0x0e  /* set = touch switch turned on (touch 
> events off) */

I do not think we should be adding this as is as it seems to be very
wacom-specific. I'd rather call it something else, like SW_MUTE_DEVICE
or similar.

I also wonder if this should really be a switch: can you query it's
state? What happen if user plugs in the device, engages the switch and
then [re]loads the driver? Will the state be still signalled properly?
What about suspend/resume or hibernation?

Thanks.

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to