Hi, currently I discovered the possibility that device file numbers of the input subsystem could go negative when the signed int "border" is passed. To fix this behaviour I sent a patch a few minutes ago.
But as the subject says there is currently the (theoretical) possibility that the same input device file name is given out twice. This can happen if the "input_no" variable had an overflow (due to the fact this is at least at 2^32 I call the issue theoretical). If such a case occurs a -EEXISTS is returned at the creation of the file. IMHO it would be a good idea to check if the chosen input device file name is valid at the point it is created (which is currently input_allocate_device). So you can just increment and check it again until there's a valid number/name found for it. I'm pretty new to the input subsystem, so what do you think about it? Any comments/ideas? Would there be a better place to do such checking? regards, richard -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html