On 11/04/2015 02:08 PM, mchri...@redhat.com wrote:
From: Mike Christie <mchri...@redhat.com>
In later patches the op will no longer be a bitmap, so we will
not have REQ_WRITE set for all non reads like discard, flush,
and write same. Drivers will still want to treat them as writes
for accounting reasons, so this patch adds a helper to translate
a op to a data direction.
Signed-off-by: Mike Christie <mchri...@redhat.com>
---
include/linux/blkdev.h | 12 ++++++++++++
1 file changed, 12 insertions(+)
diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h
index 19c2e94..cf5f518 100644
--- a/include/linux/blkdev.h
+++ b/include/linux/blkdev.h
@@ -586,6 +586,18 @@ static inline void queue_flag_clear(unsigned int flag,
struct request_queue *q)
#define list_entry_rq(ptr) list_entry((ptr), struct request, queuelist)
+/*
+ * Non REQ_OP_WRITE requests like discard, write same, etc, are
+ * considered WRITEs.
+ */
+static inline int op_to_data_dir(int op)
+{
+ if (op == REQ_OP_READ)
+ return READ;
+ else
+ return WRITE;
+}
+
#define rq_data_dir(rq) ((int)((rq)->cmd_flags & 1))
/*
How about introducing two functions - op_is_write() and op_is_read() ? I
think that approach will result in shorter and easier to read code in
the contexts where these functions are used.
Bart.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/