On Tue, Dec 15, 2015 at 09:31:39AM +0100, Vlastimil Babka wrote: > On 12/14/2015 04:26 PM, Joonsoo Kim wrote: > >2015-12-14 19:07 GMT+09:00 Vlastimil Babka <vba...@suse.cz>: > >>On 12/14/2015 06:02 AM, Joonsoo Kim wrote: > >>> > >> > >>Acked-by: Vlastimil Babka <vba...@suse.cz> > >> > >>Note that until now in compaction we've used basically an open-coded > >>round_down(), and ALIGN() for rounding up. You introduce a first use of > >>round_down(), and it would be nice to standardize on round_down() and > >>round_up() everywhere. I think it's more obvious than open-coding and > >>ALIGN() (which doesn't tell the reader if it's aligning up or down). > >>Hopefully they really do the same thing and there are no caveats... > > > >Okay. Will send another patch for this clean-up on next spin. > > Great, I didn't mean that the cleanup is needed right now, but > whether we agree on an idiom to use whenever doing any changes from > now on.
Okay. > Maybe it would be best to add some defines in the top of > compaction.c that would also hide away the repeated > pageblock_nr_pages everywhere? Something like: > > #define pageblock_start(pfn) round_down(pfn, pageblock_nr_pages) > #define pageblock_end(pfn) round_up((pfn)+1, pageblock_nr_pages) Quick grep shows that there are much more places this new define or some variant can be used. It would be good clean-up. I will try it separately. Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/