On 3/7/16 3:08 AM, Daniel Borkmann wrote:
On 03/07/2016 02:58 AM, Alexei Starovoitov wrote:
[...]
---
  include/linux/bpf.h      |   1 +
  include/uapi/linux/bpf.h |   3 +
  kernel/bpf/hashtab.c     | 264
++++++++++++++++++++++++++++++++++-------------
  kernel/bpf/syscall.c     |   2 +-
  4 files changed, 196 insertions(+), 74 deletions(-)

Shouldn't all other map types (like array) need something like this as
well to
reserve this for their future flags?

   if (attr->map_flags)
     return ERR_PTR(-EINVAL);

yeah. good point. will add another patch for that.

diff --git a/include/linux/bpf.h b/include/linux/bpf.h
index 4b070827200d..c81efb10bbb5 100644
--- a/include/linux/bpf.h
+++ b/include/linux/bpf.h
@@ -37,6 +37,7 @@ struct bpf_map {
      u32 key_size;
      u32 value_size;
      u32 max_entries;
+    u32 map_flags;

Just naming this 'flags' doesn't work due to the anonymous struct inside
that
union, right? :/

yep. exactly. there is already 'flags' member there.


+#define BPF_F_NO_PREALLOC    (1ULL << 0)

Nit: Should better be (1U << 0) as map_flags are of __u32.

right. will do.

Reply via email to