Currently special(system) irq definition layout is a bit random, due to quite a long period of code shuffle and refactorization, making native_init_IRQ() quit hard to follow.
Besides, there are also some leftovers on the vector layout comment. For example, INVALIDATE_TLB_VECTOR_START vectors have gone by using generic IPI mechanism(see commit 52aec3308db8). VSYSCALL_EMU_VECTOR is also gone because vsyscalls are emulated by instruction fault traps(see commit 3ae36655b97a). This patch set aims at refactoring the speical vector defnition and do some cleanup. *** Test done *** This patch set has been rebased on tip/master and have done build test and run it for hours, doing daily jobs, and found no problem. Jianyu Zhan (3): x86/asm/irq: Rearrange definitoin of specical irq vectors and cleanup. x86/irq: refactor native_init_IRQ x86/irq: update first_system_vector only when X86_LOCAL_PIC is on arch/x86/include/asm/desc.h | 2 ++ arch/x86/include/asm/irq_vectors.h | 72 +++++++++++++++++++++++++++++--------- arch/x86/kernel/irqinit.c | 71 +++++++++++++++++++++---------------- 3 files changed, 97 insertions(+), 48 deletions(-) -- 2.4.3