Ingo Oeser <[EMAIL PROTECTED]> writes:

> Hi Eric,
>
> On Tuesday, 16. January 2007 17:39, Eric W. Biederman wrote:
>> diff --git a/drivers/parport/procfs.c b/drivers/parport/procfs.c
>> index 2e744a2..5337789 100644
>> --- a/drivers/parport/procfs.c
>> +++ b/drivers/parport/procfs.c
>> @@ -263,50 +263,118 @@ struct parport_sysctl_table {
>> +            {
>> +                    .ctl_name       = DEV_PARPORT_BASE_ADDR,
>> +                    .procname       = "base-addr",
>> +                    .data           = NULL,
>> +                    .maxlen         = 0,
>> +                    .mode           = 0444,
>> +                    .proc_handler   = &do_hardware_base_addr
>> +            },
>
> No need to initialize to zero or NULL. Just list any variable, which is NOT 
> zero
> or NULL.

Agreed.  In this case it was left for clarity.

>> +            {
>> +                    .ctl_name       = DEV_PARPORT_AUTOPROBE + 1,
>> +                    .procname       = "autoprobe0",
>> +                    .data           = NULL,
>> +                    .maxlen         = 0,
>> +                    .maxlen         = 0444,
>> +                    .proc_handler   =  &do_autoprobe
>> +            },
>
> Typo here? .mode = 0444 makes mor sense.

Yep looks like it.  On my todo.

Eric
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to