> +#define CHARGER_DIR_NAME             "CROS_USB_PD_CHARGER%d"
> +#define CHARGER_DIR_NAME_LENGTH              sizeof(CHARGER_DIR_NAME)
> +
> +#define MANUFACTURER_MODEL_LENGTH    32
> +
> +struct port_data {
> +     int port_number;
> +     char name[CHARGER_DIR_NAME_LENGTH];

That's not really correct, right? If we ever have more than 99 such
chargers...

-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) 
http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Reply via email to