On Fri, Mar 09, 2007 at 02:05:24PM +1100, Rusty Russell wrote:
> diff -r fdc8cbc1fd61 drivers/block/lguest_blk.c
> --- a/drivers/block/lguest_blk.c      Thu Mar 08 13:35:39 2007 +1100
> +++ b/drivers/block/lguest_blk.c      Thu Mar 08 15:51:55 2007 +1100
> @@ -45,6 +45,16 @@ struct blockdev
>       struct request *req;
>  };
>  
> +/* Jens gave me this nice helper to end all chunks of a request. */
> +static void end_entire_request(struct request *req, int uptodate)
> +{
> +     if (end_that_request_first(req, uptodate, req->hard_nr_sectors))
> +             BUG();
> +     add_disk_randomness(req->rq_disk);
> +     blkdev_dequeue_request(req);
> +     end_that_request_last(req, uptodate);
> +}

I think we really want this in common code, ll_rw_blk.c should have:

static int __end_request(struct request *req, int uptodate,
                unsigned int sectors)
{
        if (!end_that_request_first(req, uptodate, sectors)) {
                add_disk_randomness(req->rq_disk);
                blkdev_dequeue_request(req);
                end_that_request_last(req, uptodate);
                return 1;
        }
        return 0;
}

/* TODO: add kerneldoc comment */
/* XXX: should be called end_partial_request */
void end_request(struct request *req, int uptodate)
{
        __end_request(req, uptodate, req->hard_cur_sectors);
}

/* TODO: add kerneldoc comment */
void end_entired_request(struct request *req, int uptodate)
{
        if (!__end_request(req, uptodate, req->hard_nr_sectors))
                BUG();
}

the latter two maybe as inlines
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to