Doubly linked lists which are  iterated  using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro.
This makes the iteration simpler and more readable.

This patch replaces the while loop containing list_empty and list_entry
with list_for_each_entry_safe.

This was done with Coccinelle.

@@
expression E1;
identifier I1, I2;
type T;
iterator name list_for_each_entry_safe;
@@

T *I1;
+ T *tmp;
...
- while (list_empty(&E1) == 0)
+ list_for_each_entry_safe (I1, tmp, &E1, I2)
{
...when != T *I1;
- I1 = list_entry(E1.next, T, I2);
...
}

Signed-off-by: simran singhal <singhalsimr...@gmail.com>
---
 drivers/staging/lustre/lustre/ptlrpc/sec_gc.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/lustre/lustre/ptlrpc/sec_gc.c 
b/drivers/staging/lustre/lustre/ptlrpc/sec_gc.c
index 8ffd000..fe1c0af 100644
--- a/drivers/staging/lustre/lustre/ptlrpc/sec_gc.c
+++ b/drivers/staging/lustre/lustre/ptlrpc/sec_gc.c
@@ -98,12 +98,11 @@ void sptlrpc_gc_del_sec(struct ptlrpc_sec *sec)
 static void sec_process_ctx_list(void)
 {
        struct ptlrpc_cli_ctx *ctx;
+       struct ptlrpc_cli_ctx *tmp;
 
        spin_lock(&sec_gc_ctx_list_lock);
 
-       while (!list_empty(&sec_gc_ctx_list)) {
-               ctx = list_entry(sec_gc_ctx_list.next,
-                                struct ptlrpc_cli_ctx, cc_gc_chain);
+       list_for_each_entry_safe(ctx, tmp, &sec_gc_ctx_list, cc_gc_chain) {
                list_del_init(&ctx->cc_gc_chain);
                spin_unlock(&sec_gc_ctx_list_lock);
 
-- 
2.7.4

Reply via email to