> Maybe we could do two phases? One to s/BUG/WARN/ and the second to > improve the message?
s/fortify_panic/fortify_overflow/ + use WARN + remove __noreturn makes sense as one commit. Still think the *option* of __noreturn + BUG should be kept there even just for measuring the size overhead. !COMPILE_TIME && EXPERT if it needs to be for now. If you're fully removing __noreturn then the entry in tools/objtool/check.c for __noreturn functions also won't make sense (either way it needs to use the new name). I think improving error messages should be done a bit differently though and it'll be easier to not tie these things together.