On 11/9/17, Djalal Harouni <tix...@gmail.com> wrote:

> +struct proc_fs_info {
> +     struct pid_namespace *pid_ns;
> +};

> +static inline struct proc_fs_info *proc_sb(struct super_block *sb)
> +{
> +     return sb->s_fs_info;
> +}

Can you rename this to "struct proc_super_block *" then?
That "info" suffix all over filesystems doesn't add much info itself
just more typing.
Ditto for "fs_info" identifiers.

> +extern inline struct proc_fs_info *proc_sb(struct super_block *sb)
> { return NULL;}

extern inline?

Reply via email to