On Tue, May 08, 2007 at 04:40:36PM -0600, Matthew Wilcox wrote:
> On Wed, May 09, 2007 at 12:29:27AM +0200, Nick Piggin wrote:
> > On Tue, May 08, 2007 at 09:06:32AM -0600, Matthew Wilcox wrote:
> > > On Tue, May 08, 2007 at 01:37:09PM +0200, Nick Piggin wrote:
> > > > --
> > > > Introduce test_and_set_bit_lock / clear_bit_unlock bitops with lock 
> > > > semantics.
> > > > Add non-trivial for powerpc and ia64. Convert page lock, buffer lock,
> > > > bit_spin_lock, tasklet locks to use the new locks.
> > > 
> > > The names are a bit clumsy.  How about naming them after the effect,
> > > rather than the implementation?  It struck me that really these things
> > > are bit mutexes -- you can sleep while holding the lock.  How about
> > > calling them bit_mutex_trylock() and bit_mutex_unlock()?
> > 
> > bit_spin_trylock / bit_spin_unlock be OK? ;)
> 
> We already have a bit_spin_trylock -- it keeps preempt disabled until
> you bit_spin_unlock.  Oh, and it only actually sets a bit if you've got
> SMP or lock debugging on.  Nice try though ;-)

OK, I'll be blunt then. I think s/test_and_set_bit_lock/bit_mutex_trylock
is much worse ;)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to