On Thu, Feb 08, 2018 at 10:36:35AM +0900, Sergey Senozhatsky wrote:
> On (02/07/18 13:05), Andrew Morton wrote:
> [..]
> > hm.  This is assuming that "cluster==true" means "this is thp swap". 
> > That's presently true, but is it appropriate that get_swap_pages() is
> > peeking at "cluster" to work out why it is being called?
> > 
> > Or would it be cleaner to do this in get_swap_page()?  Something like
> > 
> > --- a/mm/swap_slots.c~a
> > +++ a/mm/swap_slots.c
> > @@ -317,8 +317,11 @@ swp_entry_t get_swap_page(struct page *p
> >     entry.val = 0;
> >  
> >     if (PageTransHuge(page)) {
> > -           if (IS_ENABLED(CONFIG_THP_SWAP))
> > -                   get_swap_pages(1, true, &entry);
> > +           /* Frontswap doesn't support THP */
> > +           if (!frontswap_enabled()) {
> > +                   if (IS_ENABLED(CONFIG_THP_SWAP))
> > +                           get_swap_pages(1, true, &entry);
> > +           }
> >             return entry;
> >     }
> 
> I have proposed exactly the same thing [1], Minchan commented that
> it would introduce frontswap dependency to swap_slots.c [2]. Which
> is true, but I'd still probably prefer to handle it all in
> get_swap_page. Minchan, any objections?

I didn't want to spread out frontswap stuff unless it has good value
because most of frontswap functions are located in mm/swapfile.c
at this moment. It gives me good feeling frontswap's abstraction
is wonderful.
However, if frontswap matainer has no problem, I am not against, either.

Thanks.

Reply via email to