On Mon, Mar 12, 2018 at 09:03:16AM -0500, Bjorn Helgaas wrote: > On Mon, Mar 12, 2018 at 01:04:02AM -0700, Christoph Hellwig wrote: > > > + * We assume we can manage these PCIe features. Some systems may > > > + * reserve these for use by the platform itself, e.g., an ACPI BIOS > > > + * may implement its own AER handling and use _OSC to prevent the > > > + * OS from interfering. > > > + */ > > > + bridge->use_aer = 1; > > > + bridge->use_hotplug = 1; > > > + bridge->use_pme = 1; > > > > If we start out with enabled maybe these should be disable_foo flags > > instead? > > I went back and forth on that. "disable_foo" is nice because the > default value is correct (zero means enabled). But then you end up > with things like: > > if (pcie_ports_native || !host->disable_hotplug) > > where the "!host->disable_hotplug" is a double negative, and I have a > really hard time reading that.
native_hotplug or, if you want it reversed, platform_hotplug (or firmware_hotplug?) might improve readability. Thanks, Lukas