>>  fail1:
>>       class_destroy(internal->class);
>>
>> +fail0:
>
> GW-BASIC sytle label names are an anti-pattern.  It's better to name the
> labels after what they do, just like function names describes what the
> function does.  Here it would be "goto clear_desc;" or something.  It
> doesn't have to be perfect but so long as you *try* to name it something
> useful that's better than not trying.
>
>> +     mutex_lock(&g_mutex);
>>       g_descs[desc_idx].driver_desc = NULL;
>> +     mutex_unlock(&g_mutex);
>>       return ret;
>>  }
>
> regards,
> dan carpenter

Thanks, I'll fix up the newly-added one in a respin of this patch and
fix up existing labels in a future patch.

-- 
Todd

Reply via email to