On Thu, 23 Aug 2018 14:33:32 -0500
"Gustavo A. R. Silva" <gust...@embeddedor.com> wrote:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct foo {
>       int stuff;
>         void *entry[];
> };
> 
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, 
> GFP_KERNEL);
> 
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
> 
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);

Oh, I didn't know about that one. That's nice!

> 
> Signed-off-by: Gustavo A. R. Silva <gust...@embeddedor.com>

Reviewed-by: Boris Brezillon <boris.brezil...@bootlin.com>

> ---
>  drivers/mtd/nand/raw/jz4780_nand.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/mtd/nand/raw/jz4780_nand.c 
> b/drivers/mtd/nand/raw/jz4780_nand.c
> index db4fa60..ac62395 100644
> --- a/drivers/mtd/nand/raw/jz4780_nand.c
> +++ b/drivers/mtd/nand/raw/jz4780_nand.c
> @@ -352,7 +352,7 @@ static int jz4780_nand_probe(struct platform_device *pdev)
>               return -ENODEV;
>       }
>  
> -     nfc = devm_kzalloc(dev, sizeof(*nfc) + (sizeof(nfc->cs[0]) * 
> num_banks), GFP_KERNEL);
> +     nfc = devm_kzalloc(dev, struct_size(nfc, cs, num_banks), GFP_KERNEL);
>       if (!nfc)
>               return -ENOMEM;
>  

Reply via email to